对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

解决办法1:

服务器是windows 2008 server   环境是IIS7
SSL是申请用的阿里免费。微信小程序发现wx.request,调试报错: 小程序要求的 TLS 版本必须大于等于 1.2
对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

直接说解决办法吧:在PowerShell中运行一下代码(复制粘贴即可),PowerShell窗口打开方式可以用下面任意一种
1:开始->运行->输入 PowerShell
对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

 

2:开始->所有程序->附件 找到

对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

解决办法2:

request:fail 小程序要求的 TLS 版本必须大于等于 1.2

request:fail 小程序要求的 TLS 版本必须大于等于 1.2

即当前客户端版本的tls多低,

开发环境,项目---》勾选不校验即可

对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

weinxin
我的微信
把最实用的经验,分享给最需要的读者,希望每一位来访的朋友都能有所收获!

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: